Debian.pro

Блог для пользователей и администраторов Debian


Atheros ar5001 и Ubuntu 10.04 Lucid

Попал ко мне в руки asus eeepc 1000hg. Само собой, первым делом, на него была установлена Ubuntu 10.04 (не пинайте, сам ноут предназначался не для моего использования). Все железо заработало отлично, за исключением wi-fi модуля, которым оказался чип ar5001 от компании Atheros. А точнее — AR5001 Wireless Network Adapter

В чём выражается проблема. В первую очередь в том, что постоянно теряется соединиение с любой wifi сетью.

Первым советом, встреченным в сети был совет установить wireless-lucid-backports (точное название пакета уже не вспомню). И ещё несколько backports пакетов. Ни в коем случае не делайте этого. На стабильность соединения это никак не влияет, а вот скорость соединения ощутимо снижается. У меня с этими пакетами скорость упала до ~400 байт в секунду. Да-да, именно байт. Если вы ставили пакеты *-backports-* по совету на буржуйском форуме — удалите их прямо сейчас.

Собственно сейчас wifi модуль работает отлично. Решением было обновить ядро до 2.6.33. Привожу решение проблемы в одну команду, пусть и большую. Знающие — разберутся что именно делает эта команда, незнающие — просто введите эту команду и перезагрузитесь.

inky@eeepc:~$ mkdir kernel && cd kernel/ && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33/linux-headers-2.6.33-020633_2.6.33-020633_all.deb && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33/linux-headers-2.6.33-020633-generic_2.6.33-020633_i386.deb && wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v2.6.33/linux-image-2.6.33-020633-generic_2.6.33-020633_i386.deb && sudo dpkg -i linux-headers-2.6.33-020633_2.6.33-020633_all.deb && sudo dpkg -i linux-headers-2.6.33-020633-generic_2.6.33-020633_i386.deb && sudo dpkg -i linux-image-2.6.33-020633-generic_2.6.33-020633_i386.deb && sudo update-grub && cd .. && rm -r kernel/

Всё. При загрузке у вас автоматически должно загруузиться новое ядро (если это не происходит — выберите его в меню Grub, а потом исправьте grub.conf). Ar5001 теперь работает в вашей Ubuntu 10.04. Без всяких глюков и ошибок.

P.S. — тем кто думает, что это проблема убунты — попробуйте поставить драйвера на ar5001 в хрюше SP2 ;)


Комментарии (5):

  1. poliak-man :

    а вообще, есичесно,- нефиг буки с атэросом покупать.

  2. ну да.. их раньше вообще хотелось убить, за геморр с их модулями.

  3. Так их. Linux rules!

  4. odmin :

    у меня на kubuntu 10.10 более новое ведро! но лагало! ввёл команду, правда пришлось сделать su — b ec` завертухалось нормалььно! вопрос на засыпку: ставил кубунту — всё было нормально обновился — начались пляски-тряски.. ВОПРОС нах мне такие обновления???????

  5. Вот поэтому именно дебиан =)

Написать комментарий